Electron app window is not displayed on Ubuntu version 15.10


#1

On Ubuntu, in the application folder, I ran npm install and then npm start.

stpl@stpl-Lenovo-B490:~/electron-quick-start$ npm start

electron-quick-start@1.0.0 start /home/stpl/electron-quick-start
electron .
stpl@stpl-Lenovo-B490:~/electron-quick-start$

Immediately quits without displaying the application window.


#2

I am all the sudden getting this on 64bit Linux with electron-prebuilt 1.2.4 as well. Clean install of the electron-quick-start application as well as my own applications.

UPDATE: Just downgraded to electron-prebuilt@1.2.3 and it seems to have solved the problem! Still no idea of it’s cause.


#3

Thank you, this worked for me too!


#4

This is a known issue, stick to v1.2.3 on Linux until v1.2.5 comes out.


#5

Last night I was getting this error again with 1.2.3 so I just went down the list of version through 1.1.1 and got nowhere. Finally I gave up to work on it this morning and all the sudden it works with all the versions tried previously (sans 1.2.4)! My best guess is I had corrupted/incomplete downloads. Now when trying to install 1.2.4 the new 1.2.5 installs instead. Thank you Electron team, this was a pleasant surprise this morning.