Editor Lag


#1

When I tab into my atom editor, I experience several seconds where there is no response to key presses. Once the editor catches up the key presses appear in the code. This lag also occurs when typing certain characters such as semi-colon ( ; )

I have an i5-6300U processor and 8GB of RAM, and when monitoring the task manager there is no notable spike in processing power or RAM usage. I also have tried disabling all community packages to no avail.


Atom is slow
#2

Have you taken a look at the Debugging section of the Atom Flight Manual? There are instructions there on how to gather information on performance problems such as you’re experiencing.


#3

So based on that, I seem to be experiencing a runtime issue, I ran a CPU profile however it doesn’t show anything like what is shown in the linked section.


#4

All that’s showing is idle time, so the renderer process is doing literally nothing. You don’t get anything like this?

That’s from me starting the profile, waiting about ten seconds and then clicking stop.


#5

I didn’t the first time, however repeating my actions gave me this, that is me starting profile and performing the slow action (clicking into the atom editor from chrome)


#6

Looks like a bunch of stuff referencing ember in the file names. What package do those files belong to?


#7

I don’t know, I currently only have the core packages enabled.

How would I go about checking these core packages to find which is using ember? Or can you do that from your end?


#8

None of the core packages use ember, to my knowledge. But you can get the full path for any of those files by hovering over them. If you can share one or more of them, then we can get closer to what might be causing the problem.


#9

Okay, I believe that those are part of the CDN employed by my place of business and as such cant really be changed or removed in this environment.


#10

So you have a package that is executing code within Atom from a CDN supplied by your employer?

Can you reproduce this problem in Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#11

No package in Atom, but on the computer in general and yes after launching in safe mode the error still occurs and the cpu profile still contains ember calls.


#12

From where did you install Atom?


#13

I downloaded the latest version early last week from atom.io and installed it with default settings


#14

If you wouldn’t mind saving the profile, zipping it up and emailing it to us at atom@github.com, I’d like to take a look at it.


#15

So, what happend here? Did you find the solution? I have the same issue :frowning: and would love to keep using ATOM


#17

I am also having the same issue but I still love atom and don’t want to switch to anything else. Is there a solution for this issue?


#18

Same here. I’m experience the same lag problems and I would like to continue using Atom but like this it is not possible. Any idea what this may be?


#19

Hello.

Everyone’s situation is different, so it becomes extremely difficult to guess what the situation for you might be. For all we know you might be trying to run Atom on 80486 with Windows '98 or you may be on Atom V1.10.

Does your situation improve when running Atom in safe mode? (http://flight-manual.atom.io/hacking-atom/sections/debugging/) If you do still have issues, I would recommend deactivating the core Packages that has anything to do with Git and Github.

Regards.