Editor is not responding at start


#1

When i try to open any project editor is just indexing. And when I try to perform a click, it gives me such message:


#2

Does this occur when you start Atom from the command line with atom --safe?


#3

I’m getting this error even with safe mode. even uninstall and reinstall didn’t help. and basically keep waiting just result another “Editor not responding” error. I’m using windows version on windows 10


#4

Did it start recently? What happens if you rename the .atom folder in your user directory?


#5

It started recently. After installing a couple of packages (Emmet was one I guess). During install (after uninstall) it does not ask for folder as far as I remember. I was wondering if there is a way if we uninstall all packages via command line. Although safe mode didn’t work


#6

You can “uninstall” all packages by renaming the .atom folder. Please tell me what happens when you do that.


#7

tried again. no option for assigning folder. only an animation with message atom being set up and then launch which wont respond


#8

Why are you trying to reinstall it? Just go into your user directory and change the name of .atom to something else. Uninstalling Atom does not remove that folder, since that’s where the configuration files are stored.


#9

That worked. So basically uninstal leaves everything as it is probably. Thanks a lot. I was looking for folder in program files with no luck


#10

It’s difficult to tell from the information available if your issue is caused by a configuration or stored information, but since you were experiencing it in safe mode, it’s probably not any one of your packages. You can try adding them back in to the new .atom directory that got generated when you started Atom without one. You can also copy over your config.cson, styles.less, and init.coffee, keeping in mind that somewhere you might have a bit of code or a setting that causes Atom to hang on start (it would be profitable to reload with ctrl-shift-f5 with every few things you move, and if Atom starts to hang again, you have a better idea of where to look).


#11

I’m having the same problem. It still happens in safe mode, and it also keeps happening after removing the .atom folder in my home folder.

It only stops when I remove the %APPDATA%\Atom\IndexedDB folder. But then I will loose all my unsaved progress. This started happening after a power loss.

Any other ideas?


#12

Instead of deleting this manually, you should use the atom --clear-window-state command described in the Debugging guide in the Atom Flight Manual.


#13

The other part of the question was that there’s unsaved progress in the IndexedDB that would be painful if lost. Is there a way to dig around in the IndexedDB without having to have Atom open for the dev console?


#14

Theoretically, you could replace your Chrome IndexedDb with the Atom one and use the Developer Tools within Chrome to poke around in there. I would strongly recommend backing everything up first before you do though.


#15

In that case, @rsvargas can back up Atom’s IndexedDB and leave that directory empty so that Atom creates a new one and is usable again. Then an experiment can be undertaken to open it with a different set of Chrome dev tools (either Chrome or another Electron program) and see how much data can be recovered.