Eclipse-like Workspaces?


#1

I recently discovered Atom and so far I quite like it. I’ve been using Eclipse for a few years for PHP/HTML/CSS/Javascript projects, but I’ve grown tired of how sluggish it’s become, and upgrading to the newest version hasn’t been graceful at all. I’ve looked at some other IDEs/editors, and NetBeans 8.0 came close to what I needed (my needs are minimal; more than anything I need something that manages projects and is a decent editor; everything else is fluff for me), but it doesn’t save my open files layout like Eclipse does, so I started looking for an editor that does, and came across Atom, which seems to do what I need.

But something I liked about Eclipse is that it would ask me at startup which workspace to use. This allowed me to have different workspaces for different projects, so whenever I started it, I would select what I wanted to work on and it would load the project and my layout accordingly.
With Atom, it just automatically loads the project I was working on the last time I closed it, which isn’t terrible, but it seems a bit unnecessary if I want to work on another project, and I tend to jump between different projects quite a bit.

I’ve installed the project-manager package and it generally seems to handle project management well, but it’d be nice to be able to pick the project when I start Atom and before it actually renders the editor window, instead of having Atom load an entire project and then have to load another project and close the initial window.

Is there any way of accomplishing this? I’ve tried launching Atom from the CLI in different directories but I always get the same result, and my searches online haven’t turned up anything.

(Please forgive me if this post isn’t placed in the correct/any category or reeks of ‘noob’. Hoping someone out there can steer me in the right direction.)

Thanks


#2

If you launch Atom from the root directory of a project with atom ., it will load whatever the last state of that project was.


#3

Ah! I thought I tried that and got the same result, but I just tried it again and it seems to be working now.
It isn’t as graceful of a solution as I was hoping for, but I can work with this.
Thanks!