EACCESS errors


#1

I use the floobits package and the platformio-ide-terminal package. Today, when I opened Atom, they both stopped working, so I tried to update the first one, and got this message:

Then, I tried changing the file permissions for ‘/Users/Ryan/.atom/.apm/underscore/1.9.1’ so that everybody would have write permission, and this happens:

sudo chmod /Users/Ryan/.atom/.apm/underscore/1.9.1 a+w
chmod: Invalid file mode: /Users/Ryan/.atom/.apm/underscore/1.9.1

I don’t know anything about anything - how do I fix this?


#2

The permission is being denied for the mkdir command, so you can’t change the permission of a folder that doesn’t exist. Did you start Atom or run apm using sudo at any point?

What happens if you delete the .apm/ folder? It’s just a cache, so it’s fine to delete.


#3

I started Atom using sudo and the same problem occurred, but then I deleted the .apm/ folder and now it works. Thanks! Why did that fix the problem?


#4

Because you started Atom using sudo. Whenever you are running a program as root (which is what you are doing whenever you use sudo), any files or folders it creates will be owned by root. For cache folders, it’s simple to delete them, but you might want to follow up with a chown of the entire ~/.atom/ to make sure that there aren’t any files that you can’t access.