EACCES Error, Cannot Open App


#1

This is my first time using the application, and I have been unable to access it besides a blank browser window with DevTools open, and some error messages. I know that might sound vague, so here is the error I get inside of DevTools:

Any help would be greatly appreciated.


#2

Looks to me like the issue is there on the first line in red: Error: EACCES, permission denied '/Users/Seth/.atom' at Object.fs.mkdirSync ...

Sounds like it is trying to create the ~/.atom directory but it can’t because of a permissions issue?


#3

@leedohm I’m on OS X 10.9.2, how would I go about setting the correct permissions for the app to work correctly? Thanks for your quick response btw


#4

What are the permissions set to now? It is really strange that the permissions in your own home directory would not allow an application run as you to create a directory.


#5

it says that I have read/write access, or should I be looking for the chown output?


#6

I’m not entirely sure, really. I’m not an expert on permissions. Which version of Atom are you using? Are you running Atom from the icon? Or from the command line? Did it ever work?


#7

Tried command line as superuser and icon, nothing has worked for me so far :frowning:


#8

How and where did you install the app?


#9

Solution!!!


From Terminal: > cd /Users/Seth/Applications > ls -l -a

That output that the owner of the Atom.app was root, not me (Seth). So now to change that:

cd Atom.app/
chown -R Seth Contents

Now I owned the files, but upon inspecting the output in the Web Developer, it also had trouble making a .atom directory in my Home /Users/Seth directory.

cd /Users/Seth
sudo mkdir .atom

I had to make myself the owner of this directory.

sudo chown -R Seth .atom

Quit the program, opened it back up, and it works! (At least it launches lol)


#10

This may lead me to figure out the problem with permissions in my Applications that lead my computer to act weird, but at least I got Atom up and running :thumbsup: