Downloading packages error


#1

I’m new to atom (just downloaded it yesterday) and have very little knowledge about it.
During setup, I tried downloading some packages but encountered an error each time.
This is what it said:
“Compiler tools not found
Packages that depend on modules that contain C/C++ code will fail to install.
Read here for instructions on installing Python and Visual Studio.
Run apm install --check after installing to test compiling a native module…”
Could someone help a newbie out and let me know what I need to do to fix this issue? I’m running windows 10 64 bit.


#2

edit: I’ve already read a few posts about this topic here but didn’t really understand what to do (i’m very new to this all) so if you could explain it step by step, i would really appreciate it.


#3

Which packages did you try to install? Does every package fail? Try installing flex-tool-bar; that one has absolutely no dependence on compiler tools and is tiny.


#4

I tried downloading emmet and a few others and one from the “popular” list just to see if the problem was with the packages I was downloading but nothing worked.
I tried flex-tool-bar and it did install after a while but I got another error (check attachment). However, since this was taking too long to install (my internet speed is pretty slow), i downloaded the package file from github. Could that be the reason it installed?


#5

Okay, so you can’t install packages at all through Atom’s built-in package management? Is it the same error every time? What happens when you open the command line and type apm install emmet?

I tried flex-tool-bar and it did install after a while but I got another error (check attachment).

What does the console (View -> Developer -> Toggle developer tools, click on Console) say?

Could that be the reason it installed?

You just placed a folder with some code files into the .atom/packages/ directory where Atom puts packages that it has installed. No build step is required for flex-tool-bar, so it doesn’t need an install script to be run and can be put in place manually.


#6

I’m sorry but how do I go to command line?
the developer tools says this:
C:\Users****.atom\packages\flex-tool-bar\node_modules\atom-package-deps\lib\view.js:64 [Package-Deps] Unable to install tool-bar, Error:
gyp info it worked if it ends with ok
gyp info using node-gyp@3.4.0
gyp info using node@6.9.5 | win32 | x64
gyp http GET https://atom.io/download/electron/v1.7.11/iojs-v1.7.11.tar.gz
gyp http 200 https://atom.io/download/electron/v1.7.11/iojs-v1.7.11.tar.gz
gyp WARN install got an error, rolling back install
gyp ERR! install error
gyp ERR! stack Error: read ECONNRESET
gyp ERR! stack at exports._errnoException (util.js:1022:11)
gyp ERR! stack at TLSWrap.onread (net.js:569:26)
gyp ERR! System Windows_NT 10.0.16299
gyp ERR! command “C:\Users\javer\AppData\Local\atom\app-1.25.0\resources\app\apm\bin\node.exe” “C:\Users\javer\AppData\Local\atom\app-1.25.0\resources\app\apm\node_modules\node-gyp\bin\node-gyp.js” “install” “–runtime=electron” “–target=1.7.11” “–dist-url=https://atom.io/download/electron” “–arch=x64” “–ensure”
gyp ERR! cwd C:\Users\javer.atom
gyp ERR! node -v v6.9.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok


#7

Let me Google that for you.

gyp ERR! stack Error: read ECONNRESET

This is what I would expect if your primary problem is poor Internet connectivity.


#8

I actually spent a good 15-20 minutes googling and trying to find out how to install packages from command line before nervously asking you. Thanks.


#9

So what happens when you try apm install emmet?


#10

I went into packages and tried apm install emmet and got this:
“‘apm’ is not recognized as an internal or external command,
operable program or batch file.”


#11

Okay, you should edit your PATH variable and add an entry containing C:\Users\javer\AppData\Local\atom\bin. Then reopen the command prompt window and try again.


#12

I added a new path but it’s still giving an error that the system couldn’t find the path specified. Maybe I’m doing something wrong.
I had no issues downloading the extensions on brackets so maybe i’ll stick to it for now and go onto atom when i’m a little more experienced. Thank you for your help though, I appreciate it.


#13

I also meet the same question, I cannot download flex-tool-bar package either.What’s with me?THX


#14

I can’t possibly tell you because you haven’t provided me with the error message you receive or any information about what happens when the package download fails.