Double-pasting on ctrl+v


#1

Just built atom on my linux box. I’m running into this weird bug where Ctrl+V to paste seems to paste the clipboard contents twice. A Ctrl+V followed by a Ctrl+Z gets the desired effect, but does anyone know what would be causing that?

I feel like it might be that there are two “paste” hooks on the Ctrl+V shortcut, but no idea really.


#2

If you type ctrl-. and then try to paste something you will see what events are being called.


#3

that’s very helpful AbeEstrada. there are two events registered with the same shortcuts ‘ctrl-v’ the same for ‘ctrl-x’ and ‘ctrl-c’ in these files
’/usr/local/share/atom/resources/app/node_modules/tree_view/keymaps/tree-view.json’
’/usr/local/share/atom/resources/app/keymaps/linux.json’
deleting ‘core:paste’ from the second file fixes it for me


#4

Not sure how I should be interpreting the results from the Key Binding Resolver. I see the following right after I hit Ctrl+V

It seems like just the single core:paste action is being triggered? Is it possible that two actions are being triggered in succession and just the second one is being displayed? Is there a way to see a history of the actions triggered?

edit: formatting


#5

I have same issue under my Archlinux.

Do you think we can disable this treeview in key binding settings?


#6

Same behaviour on my Arch.
I think that the Resolver output means that only the first matching rule is applied core:paste / body.
If we delete this keybinding, the first rule that applies will be: native! => the native behaviour for ctrl-v is “paste”.
I guess the problem is not that two rules apply but that the first one: core:paste pastes two times…

Any idea how to fix it ?


#7

I have exactly the same problem, me too, on archlinux.
There is still no solution for this problem ?


#8

It’s working as expected on my Gentoo, my Key Binding Resolver looks the same as @alecb post above - being handled by core:paste - I get only one copy of the buffer pasted. I built Atom from source as of commit 87edff1e42e3a7a895d920d5c73efa5a5883b30a