Double-click highlights whole of variable (in PHP)


#1

Hey all,

When using Atom 1.0 I noticed a rather tedious change, when I’m codin’ in PHP and double-click a variable, it highlights the whole of the variable

Before, it used to highlight the variable name and exclude the “$”, is there a way to change syntax highlighting or is this a thing I cant change?


#2

Looks like it was changed here:

I believe you can set the non-word characters as a language-specific configuration, but I haven’t tried it.


#3

Ah danke :smile:


#4

It seems that this doesn’t work (I tried to change the general settings, too) :


#5

Forgot to reply after “Ah Danke” and it didn’t work for me either, sorry for late reply!


#6

@leedohm

Is there any further development on this issue? :stuck_out_tongue:


#7

I put this into my non-word character field and it worked.

$/()"’:,.;<>~!@#%^&*|+=[]{}`?-

I must admit I had trouble finding the PHP-specific settings. For anyone else wondering the same, they’re under Atom > Preferences (on Mac), click the “Packages” tab in the left sidebar, search for “php” and then click the “language-php” package in the results.


#8

Thank you sir!