Double-click do not select whole variable (with $)

Hi.
I can’t find decision. It has worked before. I need to select whole variable with $.
Thanks for help

2 Likes

Same issue here on Mac with latest version and trying to copy PHP variables… very annoying

Same here,
really really annoying!

I’m in the same boat here.

Just noticed it today. I am certain that it used to function as expected where a double click within a php variable would select the variable name INCLUDING the ‘$’ prefix.

I checked the PHP package settings for the Non Word Characters. It is set to the default as it was before.

/()"’:,.;<>~!@#%^&*|+={}`?-

looking forward to a fix!

Did anyone find a fix for this? Even a temporary one?

Problem is solved!!!
So, open File->Settings->Editor. Find a param “Non Word Characters”. It has default value. Drop $ from this string.
It’s all.
Be helthy

5 Likes

Ugh, thank-you for this. I knew it, something changed. I was making all sorts of errors today because it wasn’t selecting $ along with variable names. I could swear that wasn’t happening just yesterday.

Thanks for this!!!