Disappearing elements?

Not sure what’s happening… anybody have any keys?
I’m on a fresh install of windows 10
atomDisappearingElements

The top right is supposed to show a semicolon. And the numbers on the left, of course, are suppose to show as well. It seems there is something hiding these things… but I have no idea what it could be. I’ve tried changing themes ui and syntax.

I’ve also tried restarting.

Here’s the developer tools console screenshot.

This is a temporary fix, may help find the root to the problem. I have a screenshot as well as the code I added to my style.less to semi-fix this issue.

atom-text-editor .line-number { opacity: 1; } .syntax--punctuation.syntax--terminator, .syntax--punctuation.syntax--brace, .syntax--punctuation.syntax--tag { opacity: 1; }

Does this happen when you start Atom from the command line with atom --safe?

Yes. I ran atom --safe in cmd and commented out the style above. The problem still persists.

Weird. I’ve never seen anything like that and I’m baffled at how selective the disappearances are. If there’s not a package involved, I’m mystified about what could be happening.

Try disabling Tree-sitter parsers in Settings ➔ Core?

I don’t think it should be the cause, but incorrectly built native modules can do strange things.