Disabling keybinding


#1

Hey everyone! :slightly_smiling:

So, all new to the Atom editor. Basically, I want to just completely disable a default keybinding but I am having trouble doing so.

Basically, on european keyboards the ‘ctrl-|’ shortcut is used for the logical “|” symbol, but unfortunately Atom have bound this to some code treeview functionality which is extremely annoying. So, I just want to disable it! In my own keymap.cson file I simply tried putting this:

'.platform-win32, .platform-linux': 'ctrl-|': ''

However it seems my setting is completely ignored and it just reverts to the default keybinding.

How do you completely disable a default keybinding?

Thanks!


#2

Does this work?

'.platform-win32, .platform-linux':
  'ctrl-|': 'native!'

#4

Hey john! :slightly_smiling: Unfortunately this does not work :frowning:


#5

As I have a French keyboard, I strongly recommend using the keyboard-localization package which addresses nicely these issues.


#6

Hey PhiLho! Yeah, I just discovered this package and it solved my problem nicely! Thank you for the suggestion, though!