Disabling html brackets


#1

Hello! I just installed Atom, windows 7 64bit, coming from Visual Studio, I wanted a little cute IDE as Atom, that is great,but I somehow find it annoying I can’t even code in c++ properly. First I started writing #include <iostream and it finished as #include <iostream , is there any way to disable such a thing? Also, how can i change hotkeys from altgr+b to none? in my languageset, altgr+b is { and I can’t program without those brackets much :stuck_out_tongue: Thanks!


#2

It appears that you’re the same person that posted this question to both Slack and Twitter. Have you looked into what @Wliu suggested on Slack yet?


#3

Oh, I didn’t notice you responded, sorry.
No I don’t have Emmet installed. Should I install it?


#4

No, Emmet is useful mainly for HTML coding … but it also causes problems commonly like you’re describing. Can you replicate the problem when running Atom in Safe Mode?

To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#5

No change at all.

launched with:

C:\Users\Admin\AppData\Local\atom\Update.exe --processStart atom.exe --safe
preview1:
http://killhim.php5.cz/betaweb/img/2016-02-21_19-47-27.png
preview2:
http://killhim.php5.cz/betaweb/img/2016-02-21_19-46-36.png

also, the altgr+b problem still continues, when i press ctrl+alt+b(altgr+b) it moves my cursor to left instead of creating a { bracket.


#6

Yes, see the FAQ:

I don’t think that will actually pass the --safe parameter to the Atom process. Did you see a green box on the left of the status bar like this?


#7

Thanks for the FAQ direction, it was I'm using an international keyboard and keys that use AltGr or Ctrl+Alt aren't working . Just when I come to thing of it, < and > might be different on my keyboard, I should have noticed before. Thanks for the help anyways!