Disabling Hardware Acceleration (--disable-gpu) on Windows?


#1

Hey there! I’ve been attempting to stream Atom using Open Broadcaster Software and I’ve come across an issue where OBS cannot capture the window due to hardware acceleration. I’m aware of --disable-gpu, but I’m unsure of setting it to automatically use this whenever I open Atom via opening a file that is associated with Atom or via shortcut.

Thanks!


How to use Atom with OBS
Blurry text - Windows 10 Surface Pro 3
#2

Passing the switch from the command line is the only method of doing this. If you want to always open Atom this way, you’ll have to create a script that you use to launch Atom that includes the command-line switch.


#3

If have a Mac you can use AppleScript:

Open Script Editor, type the following, save it as an application, move the application to the applications folder, then set the file you want to open to be by-default opened with whatever you saved the AppleScript as.

on open this_item
    if application "Atom" is running then
        tell application "Atom"
           open this_item
        end tell
    else
        tell application "Terminal"
            set currentTab to do script (("atom --disable-gpu open " & this_item as text) & "; exit")
        end tell
    end if
end open

For normal app opening (from the Dock or Spotlight), you can do the same thing with the following AppleScript

  tell application "Terminal"
  	set currentTab to do script ("atom --disable-gpu; exit")
  end tell

#4

Did you ever figure this out? I am having the same issues. I can disable it via git bash. But if I open Atom from the shortcut/menu it does not disable it.


#5

You can add the --disable-gpu switch to the end of the Target field in the Properties dialog of the shortcut.


#6

Where is this?


#7

Are you having difficulty finding a shortcut for Atom?


#8

Well I have the shortcut on my desktop, right click and got to properties. I then see in the shortcut section the target. My target has this:

C:\Users\Amazo\AppData\Local\atom\atom.exe --disable-gpu

This is not working though


#9

Damn. All the search results talk about doing just that, but I just tried it with --safe and it didn’t work for me, either.

Maybe you’ll need to write a .bat file to open Atom via the command line. All it would need to contain is atom --disable-gpu.


#10

In theirs they say you need to do something like

“path” --disable-gpu

I noticed that in mine if I try to put quotes around the path and hit apply they just disappear you think this would be affecting it? Also I am not sure how to do the .bat file thing.


#11

No. Quotes just indicate a whole “word” in the command string. Otherwise, spaces in the path name would completely throw off the command. C:\Users\Amazo\My Documents would be interpreted as a command to look in Amazo\ for a program called My to run a file named Documents.

Also I am not sure how to do the .bat file thing.

There are some good guides online. Try this one.


#12

User regedit to set the registery key

Computer\HKEY_CLASSES_ROOT\Applications\atom.exe\shell\open\command

to

“C:\Users\User\AppData\Local\atom\atom.exe --disable --gpu” “%1”


#13

…what happens if the user name is something like John Smith which contain a space?

How about…
%LOCALAPPDATA%\atom\atom.exe --disable-gpu %1


#14

thank you all.


#15

It’s painful having to do this on a Mac. Why can it not be added as a config option?


#16

Can anyone tell me how to do this on mac os sierra?