Disable sound when closing unsaved buffer


#1

Atom makes a sound to accompany the warning when I close a buffer with unsaved changes. I don’t want Atom to make any sounds, and I’ve already disabled the audio beep. How do I turn this off?


#2

I can’t replicate the problem you’re describing using Atom v1.16.0-dev-89e74a277 on Mac OS X 10.12.3.

Which version of Atom are you using? What platform are you running Atom on?


#3

Thanks for looking into this. Version and platform information would have been helpful from the start–my bad!

I’m running Atom 1.14.4 on Arch Linux.


#4

I can’t replicate the problem on Atom v1.14.4 either. Are you sure that it isn’t something that the OS is doing instead of Atom?


#5

It’s not the OS, per se, but I was able to track the source back to the Gnome Toolkit (GTK). After disabling event sounds globally, I no longer get the sound from Atom.

This isn’t really a perfect solution, however. GTK applications don’t behave consistently in this regard. Most don’t trigger a sound for these types of dialogs. This leads me to believe that there’s something about the way that Atom/Electron calls the GTK API which causes the sound to happen.

Anyway, I’m not bothered by needing to disable GTK sounds entirely to solve this. Thanks!