Disable multiple cursors?


#1

I find myself frequently enabling multiple cursors by mistake. I don’t use this really, so I was wondering if there is a way to disable this feature?


#2

Same here. It is so annoying that I may be forced to go back to Sublime. I can’t count the numbers of times that multiple cursors were enabled without me doing so on purpose and causing multiple errors in my code as I typed which then took time to go back and fix once I realized that multiple cursors were turned on. Why in the heck would you want to have two cursors anyway?


#3

You do realize that Sublime Text also has multiple cursors, don’t you?

The feature is incredibly useful - I can’t do without multiple cursors now that I’ve learned to use them.

You can always disable the key bindings that get you into multiple-cursor mode. One is Cmd-D – I forget what the other is (I think I have it remapped: I use Control-Shift up or down)


#4

Thanks for the response. I did not realize that Sublime also has multiple cursors, probably because not once in using Sublime have I activated them on accident which is an hourly occurrence with Atom. I am sure they are useful, I just wish it was not so easy to mistakenly activate them without knowing it. Thanks for the tips on disabling them, will give it a try.


#5

It makes me very curious as to how there could be a difference. Both just require holding down the ctrl key. There must be a usage pattern that changed when switching editors.