Disable insert of C function body with tab


#1

I’m a new student using Atom for C coding.
When I write a function type, I want to indent to the function name. However Atom insert an empty function body instead.
I just want:

void\t

But I get:

void name(/* arguments /) {
/
code */
}

My only choice is to write ´void´ then a space and then a tab. However my school is very strict about the norm so this is not a valid option, because of the empty space. Can you please tell me where I can disable this option ?


#2

This automatic insertion of the function body by tabbing is called snippets. http://flight-manual.atom.io/using-atom/sections/snippets/

What you can do is disable the snippets package. This will disable all snippets in all languages. Or you can change this specific snippet to be in the format you want, snippets are very nice once you learn to use them :smiley:

To change this specific snippet to the format you want. Go to the file menu pick snippets, if you for example want a tab after void in C++ adding the following should work:

'.source.cpp':
  'voidfunction':
    'prefix': 'void'
    'body':'void\t${1:name}(${2:/* arguments */}) {\n\t${3:/* code */}\n}'