Disable History Toolbar Animation


#1

Hello! I’ve just recently upgraded from Atom 1.7.3 (which I installed manually as there’s no Debian repository) to Atom 1.15.0. I’m enjoying the upgrade but, to my dismay, I keep seeing this animation when I type:

I have the attention span of an excited squirrel, so seeing this little spinner pop up every couple of seconds is really distracting. Is there a way to disable this thing?

Thank you!


#2

I don’t think this is something from Atom itself - more likely it’s from a community package you installed. Can you bring up the developer tools, navigate to the Elements tab, and select the spinner? That should give a clue as to what package is adding that spinner.


#3

Sure! I opened the Elements tab and found the following HTML that appears to define the spinner:

<busy-signal class="inline-block loading-spinner-tiny idle" data-original-title="" title=""></busy-signal>

That didn’t tell me much, so I grepped my .atom and discovered that I have a package installed called “busy-signal”, which is a dependency of linter. The entire purpose of this package is apparently to display that kind of animation, so now I know where to look for info. :slight_smile: Thanks!


#4

Ah, that thing. Yeah I was annoyed by that too, so I disabled it with the following styles:

busy-signal // Linter's spinning icon
{
    display: none !important;
}

Just put that in your styles.less.