Disable 'Enter' Keybinding for Autocomplete/Snippets

Hi there,

I’ve been using Atom for the better part of 2 weeks and it’s great, but it has a really annoying feature which is causing me more frustration than is needed.

When using Lua or JavaScript the autocomplete suggests a helpful function or variable to use. Now, if I do not want to use this, but instead want to simply confirm what I have just typed or go to a newline I then press the enter key. But, the autocomplete then fills in the entire function or variable it suggested in place of what I just typed. See the image below:

Using other text editors you can simply restrict autocomplete confirmations to the tab key rather than the enter key, but i’m struggling to find a way to do this as I’m not entirely sure where the autocomplete enter keybinding is. I have tried setting the spell check keybinding to unset as I thought this might have been the culprit:

'.corrections atom-text-editor[mini]': 'enter': 'unset!'

But, this hasn’t stopped it from happening. Is there any way to disable this feature? Or am I just going to have to disable autocomplete/snippets in atom entirely?

6 Likes

You’re looking for the autocomplete-plus package settings:

8 Likes

Wow… I cannot believe I was too stupid to look inside of the Autocomplete package itself. I feel like a fool. -.-

Thank you so much, this has fixed the issue and helped me greatly!

1 Like

Don’t worry about it! We all had to learn at one point. Some of us are just further along the curve than others :grinning:

1 Like

Hello

Unfortunately the above settings option is not coming on my atom.

Can you suggest any other way. Maybe a change in the keymap.cson.

Thanks

I don’t understand why you would hide this absolutely rudimentary setting anywhere other than Settings > Editor? I haven’t installed any packages, why are they even there on a clean install?

Is there any logic to this dumb separation of everything into a “package”?

That’s the point in atom… Everything is a package… If you don’t like this idea then switch to other editor