Disable ‘Enter’ confirmation keybinding for autocomplete


How do I change confirmation key from ‘Enter’ to ‘Tab’?

I’ve seen this and this which suggest changing “Keymap for confirming a suggestion” in the settings, but this option doesn’t seem to be available anymore. It just has the option to check/uncheck “Enable Keybindings”.


Be on the look-out for autocomplete-plus.

Bonus - I have added some keymap for this feature:

  'right': 'autocomplete-plus:confirm'


Thanks - I do use autocomplete-plus. When I add that script, it adds ‘right’ for confirming but does not disable ‘enter’ to confirm.

I want it to just go to a new line when I press ‘enter’, not autocomplete. I tried:

  'enter': 'unset!'
  'tab': 'autocomplete-plus:confirm'
  'up': 'autocomplete-plus:move-up'
  'down': 'autocomplete-plus:move-down'

as the documentation seems to suggest (?) which disables autocomplete on ‘enter’ key but also disables going to a new line which isn’t very helpful…


Sorry for not making it clear … my suggestion was as bonus. It was not directly linked to supplying an answer.

Have you gone to the settings of the package yet (Ctrl-,). All the settings are there.


I was being very silly - I was looking in the settings for autocomplete-python instead of autocomplete-plus. No wonder I couldn’t find it… thanks!


Yeah… that kind of things happens in the best of families. :wink:
Thanks for the feedback.