Disable CSS autocompletion on tab-button?


#1

Hi, I’ve a little problem with CSS autocompletion. When I write a css property and press tab, it seems to toggle autocompletion.
For example, I type:

img.class_x{
position
}

After “position”, I pressed tab and it autocompleted like that:

img.class_x{
position: absolute;
}

Since I like to order my css declarations with indentations using tabs, I would like to disable that. However, even when I disabled the entire autocomplete package, it didn’t change anything.

How do I get rid of that?


#2

In a CSS file, when I type foo followed by space, followed by {, I get this:

foo {@}

I’ve used @ to indicate the current cursor position. Note that I didn’t type the closing brace, it got auto-inserted. Further note that there is no character between the braces, just the cursor.

So now I hit Enter/Return and I get this:

foo {
    @
}

Again, @ marks the position of the cursor. It doesn’t look like intendation is required at that point. That said, Tab has always indented for me at the beginning of the line.


#3

Sorry, but I don’t think this really answers my question?


#4

The package that handles the auto-expansion you’re seeing is the snippets package. You might want to disable that instead.