Disable a packages key-command in favor of Atom's?


#1

Emmet has command-/ mapped to “toggle comment”, although it’s always the wrap type /* */

I notice in the menu itself, both Atom’s and Emmet’s have no valid key command visible.

How can I disable this shortcut in Emmet and Allow Atom to get the keystroke instead?


#2

https://atom.io/docs/latest/advanced/keymaps#specificity-and-cascade-order


#3

Sorry, I understand what’s being said conceptually, but what file(s) do I edit.

For example, if I click the “copy” icon next to the command in Emmet Settings I see:

'.platform-darwin .pane .editor:not(.mini)':
'cmd-/': 'emmet:toggle-comment'

So where do I go from here? Thanks.


#4

You edit your keymap.cson to add your own key binding customizations. You can find it at Atom | Open Your Keymap.


#5

Thanks. In case anyone finds this thread, I wound up adding this:

 '.platform-darwin .pane .editor:not(.mini)':
    'cmd-/': 'editor:toggle-line-comments'