Directory named "profile" hidden by Atom, including cmd-T


I understand that apparently by default Atom hides files/folders that are marked for ignore in .gitignore. I also know how to disable this behavior.

My problem is that I have a folder named “profile” a couple of levels within my project, and it is being hidden by Atom. When I uncheck the hide feature, it shows up as light gray. However, cmd-T smart file search/open fails to include any of the files under that profile folder.

My .gitignore makes no mention of “profile”, so I don’t know why it is being hidden in the first place. But even when I tell Atom not to hide things mentioned in .gitignore, it still behaves differently (but not including files in that folder for quick open via cmd-T.

Am I missing something, or is this an unexpected behavior?


Hmm, not sure what’s going on - you don’t happen to have profile listed in Settings > Core > Ignored Names?

Also, is the repo you’re working on public so we can try it out? Or can you create a public test case that reproduces the behavior?