Didn't request the admin permission during installation


#1

I am using the computer in my working site, it’s working on windows 7 with user permission.
When I have to install any software, it should pop up a login box to request the admin permission.

When I install Atom today, I didn’t see any login box popped up, then I cannot see the shortcut on my desktop or start menu. After that, I’ve tried to run the install file with the admin permission but those shortcut still not appear.

However, it is not a really big problem because I still can find the installation path from Google to start Atom, but I think it should be fixed in the next version. Thanks.


#2

Also, I have a suggestion, could Atom add a “Open with Atom” selection it windows right click properties? In notepad++, it will auto added during installation, thanks.


#3

I’m pretty certain that Atom doesn’t require admin permissions to install itself on Windows. I’m not sure why the shortcut isn’t appearing where you expect it to.

There is an open issue discussing how to do the context menu support here:


#4

I believe Atom installs to a location not requiring administrative rights to access. I use Linux or the Windows .zip so I wouldn’t know about the shortcut.


#5

That’s why I think that’s about admin permission problem, the shortcut on desktop and start menu creation may needs the admin permission to do so.

Also, if it really about the permission problem, I think that’s not a problem to add the admin permission request in windows installer, because Atom also provide the zip version and you may say that’s a portable version, if people wanna install Atom, it require a admin permission is reasonable, otherwise, they can download the zip version.


#6

The Atom installer isn’t going to be changed to require administrator permissions. See the discussion here for more background: