DevTools Always Opens in Windows 10 with White Screen in Editor


#1

I know this is a common problem, but all the solutions I’ve found around the web don’t help me. Each solution is slightly different, depending on what’s in the console. Following is the error I get. Can anyone tell what the issue is? A stylesheet?

 index.js:62 Error
    at new Parser (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\node_modules\less-cache\node_modules\le…:333)
    at LessCache.module.exports.LessCache.parseLess (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\node_modules\less-cache\lib\less-cache.…:244)
    at LessCache.module.exports.LessCache.cssForFile (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\node_modules\less-cache\lib\less-cache.…:275)
    at LessCache.module.exports.LessCache.readFileSync (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\node_modules\less-cache\lib\less-cache.…:263)
    at LessCompileCache.module.exports.LessCompileCache.read (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\less-compile-cache.js:36)
    at ThemeManager.module.exports.ThemeManager.loadLessStylesheet (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:281)
    at ThemeManager.module.exports.ThemeManager.loadStylesheet (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:257)
    at ThemeManager.module.exports.ThemeManager.requireStylesheet (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:174)
    at ThemeManager.module.exports.ThemeManager.reloadBaseStylesheets (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:237)
    at ThemeManager.module.exports.ThemeManager.loadBaseStylesheets (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:232)
    at new AtomEnvironment (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\atom-environment.js:250)
    at module.exports (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\initialize-application-window.js:19)
    at setupWindow (index.js:86)
    at window.onload (index.js:41)

#2

Looks like it is having a problem parsing a stylesheet. Is there anything in your styles.less? (Though it should still be able to display the basic UI even if the styles.less is borked.)


#3

I’m not seeing a styles.less file. Just a scrollbar.style and that’s it as far as style sheets in that path.


#4

Which path are you looking in? styles.less is in %USERHOME%\.atom\styles.less.


#5

Well, looking now in the correct place, it does exist. Funny how that helps! :slight_smile:


#6

Any idea how I might go about solving this? I hate not being able to use Atom on my Windows machine. I uninstalled Atom and reinstalled it, but that didn’t improve anything. Should I try to replace a file with an older version? Remove a file? Is there a patch? I’m not sure I’m advanced enough to debug this.

Error
    at new Parser (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\node_modules\less-cache\node_modules\le…:333)
    at LessCache.module.exports.LessCache.parseLess (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\node_modules\less-cache\lib\less-cache.…:244)
    at LessCache.module.exports.LessCache.cssForFile (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\node_modules\less-cache\lib\less-cache.…:275)
    at LessCache.module.exports.LessCache.readFileSync (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\node_modules\less-cache\lib\less-cache.…:263)
    at LessCompileCache.module.exports.LessCompileCache.read (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\less-compile-cache.js:36)
    at ThemeManager.module.exports.ThemeManager.loadLessStylesheet (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:281)
    at ThemeManager.module.exports.ThemeManager.loadStylesheet (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:257)
    at ThemeManager.module.exports.ThemeManager.requireStylesheet (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:174)
    at ThemeManager.module.exports.ThemeManager.reloadBaseStylesheets (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:237)
    at ThemeManager.module.exports.ThemeManager.loadBaseStylesheets (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\theme-manager.js:232)
    at new AtomEnvironment (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\atom-environment.js:250)
    at module.exports (C:\Users\MM\AppData\Local\atom\app-1.5.4\resources\app.asar\src\initialize-application-window.js:19)
    at setupWindow (index.js:86)
    at window.onload (index.js:41)handleSetupError @ index.js:62window.onload @ index.js:45

#7

Have you tried this?

  1. Completely exit all instance of Atom
  2. Move or delete %USERPROFILE%\.atom\storage (I got the environment variable wrong in my last post, I think)
  3. Move or delete %USERPROFILE%\.atom\blob-store
  4. Move or delete %USERPROFILE%\.atom\compile-cache
  5. Start Atom again

#8

Yes. Same story.


#9

I’m stumped. Please file a bug (if you haven’t already) on https://github.com/atom/atom/issues. When you do, please post a link to the bug here.