Development package won't load


#1

I previously created a package using package-generator in $HOME/github/language-caople . However, when I tried to edit files in that package, nothing changed even when I reloaded the Window, because it appears that Atom made a copy of the package in the packages folder that was not being kept up-to-date.

Following other advice I went to the github/language-caople folder and run apm develop language-caople, it creates a junction at $HOME/.atom/dev/packages/language-caople leading to the same directory. However, when I run Atom, the package appears in the Development section but does not work. An Install button is given for the package, but clicking it gives the message “Installing language-caople@0.0.0 failed. Request for package information failed: not found”

Can anyone tell me what is wrong and where I need to put the package for it to work?


#2

The package generator creates a symbolic link in packages/ that refers to the folder with the code in it.

When this happens, are you running Atom with the command atom -d?


#3

Ok, running with atom -d did make it work. It appears that the package generator didn’t, though. Since this is Windows there’s no such thing as a symlink, only a shortcut or a junction - perhaps it created the wrong one?

(I should also note that under Windows the usual directory used by the GitHub client is $HOME/Documents/Github not $HOME/Github so now my files are in two different places :frowning: )


#4

I’m on Windows and the recent package I made with the generator is correctly linked (I just made one, opened github/atom/my-package in Atom, edited readme.md, and went to .atom/packages/my-package where I observed that readme.md had a later modification time than everything else).

now my files are in two different places :frowning:

There’s a setting under the Core tab called Project Home. It’s a little over halfway down.