Deprecated package version question


#1

The angular-js package, which I use a lot, is flagged with 2 items by Deprecation Cop, which I reported.

However, I noticed that the version of the package in Atom is 0.1.0, but the version on atom.io is 0.2.0

Why is this?


#2

If you look at the repository, v0.2.0 requires a minimum Atom version of v0.174.0. If you’re running an older version of Atom, it won’t install the v0.2.0 of the angularjs package.


#3

I should have said I’m running the latest Atom, .199


#4

Can you go to the command line and execute apm links?


#5
charizard:~ stevel$ apm links
/Users/stevel/.atom/dev/packages (0)
└── (no links)
/Users/stevel/.atom/packages (2)
├── dendrobates-syntax -> ???
└── printen-syntax -> ???

The last 2 I recognize as themes I’ve worked on.


#6

I don’t know. I just tried installing the package and I got v0.1.0 also. You may want to report an issue on atom/apm.

/cc @thedaniel


#7

apm prints the latest version:

C:\Users\jwm\.atom>apm show angularjs
angularjs
├── 0.2.0
├── https://github.com/angular-ui/AngularJS-Atom
├── An AngularJS package for Atom
├── 27795 downloads
└── 140 stars

#8

I just installed the package manually from github.

I checked the package.json of the download, and it was indeed 0.2.0. I ran apm show angularjs and got same as @jerone did. It also said Run apm install angularjs to install this package.

So I did. I ran apm show and it said 0.2.0. Paranoid at this point, I checked the actual package.json, and it says 0.1.0!

So I reinstalled manually and I am running 0.2.0, and Deprecation Cop is happy. But it’s odd that apm keeps installing the older one.