Dependency does not seem to work


#1

I am new to atom and the package development.

I develop a small language package that depends on another package. My goal is that when the user installs my package, the dependency gets installed automatically. But my tests show that this is not the case. The package gets installed without any error message, but it does not work (as the package it depends on is not loaded). I have no idea if I have the correct syntax for the dependency.

My package is at https://github.com/speedata/atom-schema-speedata

and the package.json file has the following contents (extract)

  "package-deps": [
    "linter-autocomplete-jing"
]

Can anybody tell me (in a simple language, beginnner!) what is wrong with the code?