[DELETE] Apm disable/enable packages without adding version number?


#1

It’s really tedious to enable/disable packages. You have to write apm disable PKGNAME.VERSION it should either not require the version or needs bash completion.

UPDATE: Note that it logs a message saying the package is disabled but it won’t be when you look at settings or run apm list.

Are there any tricks here?


`apm disable` doesn't work on my machine
#2

What version of Atom are you using?

Trying it just now on v1.28.2 (edit: 1.29.0-beta2), I did not need to specify a version number. Additionally, I believe it’s easier to click the button in settings, rather than run apm commands for everything.

The only case I see myself using apm enable ... for is scripting a set of packages I want to enable / disable (not that I’ve needed to do that).


#4

Same version. I should’ve clarified that it gives a message as if it worked but if you run apm list or actually check your package settings you’ll see it wasn’t disabled.


#5

I just tried again (and also looked at the Atom package list), but it still works . I don’t know what’s wrong with your version, but it could be a bug in Atom.

I’m using macOS v10.13.5 by the way.


#6

UPDATE: This seems to be something specific to my machine, I’ll have to investigate further. Tried uninstalling atom and reinstalling from website and it still doesn’t work.

Thank you so much for trying again! You’re right that something is off and my best guess is that it’s due to the fact that I installed it using brew cask.

I’ve opened an issue here: https://github.com/Homebrew/homebrew-cask/issues/49917


#7

I highly recommend using an officially supported Atom distribution. Atom comes with it’s own auto updater, if that’s why you were using homebrew.


#8

Opened a related question here: