Default "alt-g" key binding blocks "@" character on Swiss German keyboards


#1

The Swiss German keyboard has the “@” character on “alt-g”. Unfortunately, Atom uses this key binding for git related commands. I have tried to disable these with keymap.cson lines such as:

'.workspace':
  'alt-g b': ''

Unfortunately, this doesn’t do the trick.

I’ve already sent feedback to reconsider this key binding, meanwhile, is there a way to work around this?


Cannot write the @ symbol w/ German keyboard (Windows)
#2

Yes, there is …

Closing as duplicate.


#3