Customize menu colors possible?


#1

Hi guys …

Is it possible to customize the menu colors? I’m not sure what I have done but my topmenu in Atom is very light in color with black text and thats OK, but when I hover a menu selection I get white text color and it is almost impossible to read the selected row.

I should tell ya that Im on linux (Elementary OS) with GTK. But I dont think GTK is mocking with this, coz all my other window menus in the desktop looks right.

Any suggestions … something I missed(probably :smile:)

Best regards
/Roger


#2

This has been noted in various Linux distros, and similar styling issues with the menu for Windows as well.
However, it looks like this is expected to be fixed in the next release (see this commit), which will allow the menu to use the active UI theme.


#3

Thanks for the quick response, batjko.

At the moment I am using the the build(116) from luanchpad’s PPA. Doesn’t seem to be upgraded that often though. Guess I will have to build it myself again.

Best regards
/Roger


#4

I’m afraid so. For Linux it’s only build-it-yourself at the moment. There is no automatic update or anything.
But maybe you’d like to wait for v121 to be officially released.


#5

Will do …

Thanks for the help batjko


#6

OK, did it like this. As I use nvm for node on my primary OS I dont want to put a systemwide node in place. Instead I created a virtual machine with VirtualBox, installing system wide node and building a dpkg in the virtual machine. That way I get to keep a clean environment on my main OS.


#7

And what does the menu look like now?


#8

@batjko : Still installing the virtual box :smile: Will get back with the result asap


#9

Back again :smile:

Well, it sort of worked :slight_smile: Built atom on virtual Ubuntu 14.04 64-bit, installed on XUbuntu 14.04 64-bit and all went smooth.

The top menu is in the same color as the windows decoration, including text, so you dont see the menu by default. But when you hover with the mouse, I see the text for the menu I hover. Selecting a menu work perfect though. I now got a much better color contrast, based on my current theme (Numix).

I cant say that not seeing the menu will Im working is a problem. I know its there and as soon as I hover it I see the menu right under the mouse. So this is much better. I will run with this. Will see if I can install the same package on my Elementary OS install at home tonight(at work at the moment.) Interesting to see if the package work as I think Elementary OS at the moment is based on Ubuntu 12.04. Perhaps library dependency problems will arise.

Best regards
/Roger


#10

I have an Elementary OS installation on an old laptop, on which I recently installed Atom. Didn’t notice any issues with the menu, but I haven’t actually used it yet.
I’ll rebuild and see what it looks like now.


#11

Cool … meanwhile I did testa running my atom build at home on Elementary OS but as I thought I ran into library dependency problems at home.

Error: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by /usr/share/atom/resources/app/node_modules/git-utils/build/Release/git.node)

at Error (native)
at Module.load (/usr/share/atom/resources/app/node_modules/coffee-script/lib/coffee-script/register.js:45:36)

Wrong GLIBC version in Elementary OS. Will rebuild it again under a virtual Elementary OS.


#12

I just re-built on Elementary and had no issues.
Not sure what’s up with yours. All the prerequisites from the Linux instructions should still be there from your first install, presumably.

Have you tried script/clean first? Always best before rebuilding.

This is what my menu looks now, btw:


#13

I think I know(or at least suspect) what is wrong here. I installed Ecplise last week and it played some tricks with my GTK settings. Java have a tendency to play with the GTK themes it seem :smile: I think this may have caused the problems I’m having. As I said in my urlier post, Im OK with the results I have gotten at the moment and I will leave it with that. I’ve tried the Ubuntu build on my other machine, and everything works just fine so I guess my Elementary OS GTK setup Is somewhat “borked”. When I get time, I will check my $HOME to see if I can wipe the GTK settings(to reset to default) to see if this solves the problem.

@batjko I’m really thankful for your patience and interest put down into this issue.


#14

No problem at all. Good luck!