Customization question


#1

Hey all so I’m super sick of all the little things that are supposed to help you in atom (drop downs, making another parenthesis, etc). I just want to type unassisted. Is there some way to switch to this? Thank you very much!!


#2

Look at the bracket-matcher package settings for character insertion, and autocomplete-plus for the dropdown.

If you still want autocomplete to be available, you can set the default key binding to none, and set your own. If not, you can just disable the package.


#3

Thanks for the response! I’m not quite sure how to get to character insertion. After going to Packages >> Bracket Matcher I do not see anything for character insertion. Am I looking in the wrong place?


#4

It’s this setting:


#5

I didn’t see that in the settings. Can you write instructions on how to get there? Thank you. Also do you know how to get rid of the auto-correct column that is generated when you start typing?


#6

It’s right at the top when you click on the bracket-matcher card to get to the package’s settings.

You can disable the automatic autocomplete dropdown on the autocomplete-plus settings:


#8

Which part of the settings are you seeing this in? Core and Editor don’t have either of those things for me.


#9

Settings >> Packages (between Keybindings and Themes on the side) >> disable bracket-matcher, autocomplete-plus

“He did it! The son of a b**** did it!”


#10

Each package has individual settings. You don’t need to disable them entirely, just click on the package card from anywhere you can see it (Packages, Install, and Update all work) and you’ll be taken to the package’s settings, if it has them.