Custom grammar package isn't selectable


#1

I’m writing grammar rules to support a custom language. I realize there are plenty of related topics, but none of them helped me, each one for their own reason. I have to note that there no longer is a Document on Creating a Package. Still, I can just use the command “Generate Package” and take it from there, but that’s beyond the point.

I’ve picked a couple of language-LANG packages (where LANG would be a language) and checked their code, so I got a small bit of grounds to work on. I’ve written a part of the code and would like to test it out, but I can’t select it from the languages window (that shows up after clicking the name in the bottom-right of the editor) since it doesn’t show up.

Yet, the package shows up in the list of Packages complete with all the info I gave in “package.json”. What am I doing wrong?

I’m sorry if this question is actually easy to answer, but I do a bit of research before I ask. If I missed it, it was purely out of distraction and, for that, I apologize.

EDIT 2: Problem solved. I made a dumb typo: the directory “grammars/” was named “grammar/”


#2

Do you have those line setup with CSS replaced by your language name ?
Are the cson/json files valid ?


#3

I have all of those and even a firstLineMatch.
If the files are valid, I’m not really sure: the Console doesn’t bring up any error, so I would assume they are.

Do I need to add myself the tags _id and _shasum?


#4

Never mind, everyone. I’m an idiot.

Directory that should be named “grammars” had a typo: I wrote “grammar”.


#5

You are correct … there are now two example packages in the Atom Flight Manual in Chapter 3: Hacking Atom.


#6

Correct, I noticed that; what I meant was that the specific doc referred to other Questions/Topics in this category related to this one didn’t exist anymore (I should’ve been more specific). Those two replace it (and explain the feature more extensively), but still not what I was looking for.

Anyways, I made a dumb mistake. I’m seriously sorry about this.