Cursor selection not working


#1

Just updated to 0.206.0. on linux
Using cursor for selecting text is disabled. Text selection is working only with SHIFT + ARROW keys.
I deleted every extra packages and restarted Atom. Still not working.
Is there any special setting for this?


#2

By cursor, I assume you mean the mouse?
Have you tried it in safe mode atom --safe?

I don’t have an issue with it, but I’m on Windows at the moment.


#3

Yes, i mean the mouse.
Tried launching with --safe, still the same issue.

I looked for a solution over this forum but cannot find even smilliar issue.
Now I completly removed, and installed again but even this was not helping.
Any other tips?


#4

If you check in Settings, are any core packages disabled by any chance?


#5

When im uninstalled, the .atom folder was deleted manually from my home folder to be sure every setting is gone.
Now with complete clean install. After reinstall still the sam issue. I checked the CORE packages and there was not disabled packages.

I think im going submit a bug.


#6

Problem found. There is a Chromium bug on VirtualMachine affecting the mouse(and the selection)

Solution: HostKey + i

@batjko thanx for help! I used the search only with term “cursor” and the solution was in search result when i used “mouse” :smile:


#7

Ah I didn’t know you were on a VM! I remember that other topic on this problem.

Looks like this should be working since Chrome 43 though. I’m not sure which one Atom / Electron currently come with.


#8

Since this is a duplicate of the other topic, I’m going to close this one to point people in the right direction. If there is anything else left to say on this, please continue the conversation here:


#9