Cursor Jumps over Indented Whitespace


#1

See gif - can I turn this off? (not using tabs)


#2

Have a look at this issue on the repository.
The idea is to make those soft tabs behave like hard tabs (even though they remain spaces). It’s by design apparently.


#3

There should be some way to temporarily (or permanently) disable it.


#4

Judging from the discussion on that issue, it sounds like that is going to happen.
I would start getting concerned though about the amount of configurations being put into the Settings View. At some point such rather minority requests will have to be left to people’s config.coffee, I think.


#5

That’s great to hear! My current workaround (setting tab size to 1) has lots of sideeffects.

Having the options in a file is perfectly OK. But wouldn’t it make sense to get rid of the core/editor options and put everything in a config file?


#6

Everything is in a config file, ~/.atom/config.cson. You can edit your settings through the file or through the UI.


#7

Which I think is a good way to balance the GUI-only crowd (like me on most days) with happy hackers (like me on days with a lot of intravenously fed caffeine in the morning).

On balance, then, I think the GUI ought to be the place for the most commonly changed settings, while the config file can still be used extensively for everything else people would like to do… which may feel like common sense only to me. Not sure.


#8

Do you know if/when this will be implemented? Is there an issue on Github I can track?


#9

I would still suggest the issue I linked to in my first response.
There hasn’t been much movement on this, I suppose the demand isn’t very high so far.