Cursor Issues in 0.111?


#1

Anyone else seeing strange issues with 0.111 cursor?

I have two files open and one of them, clicking a line shows the cursor at position 0, but when I type it types at the correct position. Making coding super difficult.

I didn’t see it until today, only updates I did was Atom to 0.111 and Travis-CI plugin (which I’ve disabled)


#2

I’m not seeing this. Can you reproduce the behavior with atom --safe?


#3

I had this behaviour too but for me it was due to syntax theme uninstallation. i guess some classes where not removed properly when switching between syntax themes when multiple atom windows are open.

Next unwanted behaviour was about not being able to position cursor using mouse. editor pane has not catcht click events as it seems.

3rd and last unwanted behaviour was about the atom background which was ‘shining’ through. or more overlaid. oh wait i could have checked that with dev tools. damit… next time! :slight_smile:

but issue was solved by restarting atom.


#4

Actually, I have seen a few strange cursor behaviors. Still trying to track it down.

It would be helpful if people could include the following information:

  1. Which version of Atom are you using?
  2. What OS and version are you running?
  3. Can you reproduce the issue when using atom --safe?
  4. Have you followed the suggestions in the Debug document?

#5

Looks like v0.112.0 and v0.113.0 have been released. v0.112.0 specifically has mentions of cursor issues in its patch notes:

Fixed an issue where cursor positioning was corrupted in hidden editors after changing the theme.


#6

I’m still seeing some cursor issues in v0.113.0. When using Command+D to select next the editor is jumping up to the top. Another Command+D will cause it to jump back down to the selection position, another back up, and so on. I’ve tried in atom --safe and still seeing the same issue.


#7

There have been a lot of changes around autoscroll to selection in the past few days. And it looks like there are going to need to be more, at least according to this comment from @nathansobo.

Can you file a bug on your issues on Atom Core @mrhanlon?


#8

@mrhanlon I’m guessing that you’re hitting this issue: https://github.com/atom/find-and-replace/issues/245. Turning on the react editor in settings should resolve the problem. Can you leave a comment on that issue if this is what’s been causing problems for you?

EDIT: @nathansobo just fixed that issue in Find and Replace for the old editor as well: https://github.com/atom/find-and-replace/issues/245#issuecomment-48471324


#9

Awesome, thanks. Switching to the React editor did the trick. I’ll watch for the next update to roll and test if it fixes the problem for the old editor. I guess I missed the React editor, I’ll have to take a look at exactly what that entails.