Cursor appears to be displayed one character to the right of its actual position


#1

##It seems to only happen while soft text wrap is enabled
When I use the command palette to enable soft text wrap, the typing cursor seems to be in the wrong place

##For example
"|" will denote the cursor position

-Cursor looks like this : <|div>

-I press the backspace key

-result is : |<iv>

What I’m seeing is that the cursor is ACTUALLY to the right of the “d”, but it is displayed to the left of the “d”

Anyone have insight about my d? ;)

Can anyone reproduce?


#2

I have it too, sometimes the cursor is displayed up to three or four characters of its right place.

It seems to produce when I use the system-native keystroke alt+arrow to navigate from words to words.


#3

+1, same troubles for me. Some were saying it might be a font issue, but I have the default font still. Mine also can be 3 to 4 spaces to the right at times.


#4

+1 Same problem. Editing Python code. I’ve toggled soft wrap and the issue persists. I also have the default font. My cursor can also appear to be multiple spaces away.

The problem seems to disappear when I change the font size (Command ±). (The issue appeared after reducing the font size to something quite small.)


#5

Also having the same issue, occurs a lot after highlighting sections (even manually with the mouse).


#6

This seems to happen to me when I type more than average speed. I have a very fast cursor set up on my Mac, and it is affected from that as well.

Is it a Code Mirror issue?


#8

+1

Cursor becomes out of sync with the actual insert position, happens quite a lot.

Mac 10.9.2
Atom 0.73.0


#9

This happens to me most commonly at the bottom of a file. I’m unable to properly select or edit the last line or two of the file.


#10

I have experienced this issue as well. It happens in a bunch of situations, and so far I have been able to trace it back to the following issues:

  • When opentype features are employed, I think this modifies subpixel rendering, regardless of what text-rendering set to, since you can see the line lengths change (the pink line shows comparison of ending ‘text-rendering: optimizeLegibility;’ line, and you can see the cursor way off at the end of the line of lowercase 'l’s)

  • When settings are applied to .cursor-line

  • When proportional fonts are used

Fonts: Consolas (monospaced, examples 1 and 2) Input Sans (proportional, example 3)
Atom Version 0.120.0 (0.120.0)
Mac OS 10.9.3
Retina Display


Atom writes one space back from selected
#11

Apologies, the forum would not let me post all images.

.cursor-line example:


#12

proportional font example:


#13

Has anyone been able to resolve this? I seem to have it all of a sudden.
Mac OSX 10.10.2
Atom Version 0.187.0 (0.187.0)


#14

It’s being looked into:

But it is a complex problem and will require a large amount of work to fix in all cases.


#15

With the update to the latest Atom version 1.1.0, this problem occured again on my Mac OS X 10.11.1. Any idea how to fix this? It’s really annoying

As you can see on top, the cursor is one character more to the right as it should (there is no space after the div). Below I deleted one character hitting backspace one time:


#16

Updated few minutes ago - have same problem. will look for solution to roll back.

Seems problem occurs only when I use seti syntax


#17

Are you using the seti ui/syntax themes? Looks like there is problem with those and 1.1.


#18

Yes, this problem in seti syntax. Solution is here


#19

I am having the same issue.


#20

Yes, the workaround in the github issue solved it. Thanks for pointing it out!


#21

I changed my font to Georgia and the issue was resolved. I know this is a late response (by a few years), but for anyone who still has the problem, it worked for me. I’m using a Mac and using the Safari browser.