Ctrl + S moves the cursor


#1

My cursor moves to the previous word when I invoke save via Ctrl+S. This happens only in .js files. I am trying to find the plugin which is causing this behavior but no luck so far. Any tips?


#2

You can use the key-binding-resolver (Ctrl + .) to define if there’s a command that takes precedence over the save one. But that would mean that you no longer can save a file, so it’s unlikely a command.

The debugging document is also a good starting when encountering an issue in Atom.


#3

Do you have Emmet installed?


#4

Thanks for the tip. I tried it, only core:save is getting triggered.


#5

Yes, I do. Does that have to do something to do with the key bindings?


#6

Maybe I’m grasping at straws, but try disabling Emmet and restarting Atom to see if that fixes it. Yes, Emmet does a lot with key bindings … I think only in HTML, but maybe it affects JavaScript as well. And I’ve seen a lot of issues around key bindings on the forum here fixed by either people disabling Emmet or bugs being fixed in Emmet.

Anyway … just a suggestion.


#7

Just tried uninstalling emmet, restarting atom. The problem still persists. Any other ideas to try out?


#8

Turned out to be the reason for this error. Disabled. Waiting for update.


#9

Thanks for the tip @amarprabhu, this solved it for me too. I had to restart after disabling, too.