CTRL+ left click multi cursor not working

Hi @UziTech - editing the config setting through command line as you suggested and verifying the contents in config file does NOT fix my missing multiple cursors on stable 1.48.0. Might there be anything else (other than hyperclick and IDE, which are NOT installed) that have made this stop working? First it was nightly that stopped about 2 weeks ago, then beta stopped about a week ago, now stable has stopped in 1.48.0. So something - other than the bug you referenced - has flowed down to my editor which is not fixed by the config change you posted.

@tremendus have you tried it in safe mode? That config change will fix the problem in Atom introduced in 1.48.0. If there is another problem somewhere else in your setup I would first try disabling some packages until it works too figure out which package is causing problems.

same issue here. Win10, Atom 1.48…

I hope this helps someone. When you follow UziTech’s method above, it opened for me what looked like the inspection window for a browser. I then had to click the console tab. When I entered
atom.config.set('core.editor.multiCursorOnClick', true);
as UziTech suggested, I hit enter, tested, and problem solved for now.

6 Likes

Same here. Pretty annoying. I use that feature all the time. I did recently update so I wonder if it’s just buggin out. Hope it get’s fixed soon. :triumph:

For me too ! Same problem, … waiting for a normal behaviour …
On Linux Fedora, last version, KDE Plasma

This is also happening for me, been like that for about a week. I am gonna try this cmnd line fix

Works perfectly in Atom 1.47, broken in 1.48.

1 Like

Same problem since updating to 1.48.0. The “temporary fix” above solved it for me:

4 Likes

thank you :smiling_face_with_three_hearts:

Thanks. This works like a charm.

thank you. :upside_down_face: :slightly_smiling_face: :relieved:

Thank you, great fix!

This guy is a hero

You saved me man! Thanks.

THANKS, works perfect!

Atom the … hackable editor, it seem like a hack … fearly …

You are the best man. Thanks

Thank You so much. I’m ‘completely’ new this (and getting on in years lol) and thought I was being stupid! However, even I figured out how to use your workaround and it has worked it perfectly! Seems you can “teach an old dog new tricks” afterall :grinning:

For those who couldn’t solve with the solution given by @56curious, pay close attention to your config.cson file, in my case had this line welcome:atom.config.set('core.editor.multiCursorOnClick', true); that I think I had mispasted it, so when I deleted, the multi cursor back to work: