CTRL+ left click multi cursor not working

I’m seeing this as well after updating.

PR #20804 has been merged to fix this. It should be fixed in the next release.

For a temporary fix:

  1. Open the console (Ctrl + Shift + I) (Alt + Cmd + I on MacOS)
  2. run atom.config.set('core.editor.multiCursorOnClick', true);
66 Likes

Oh thank god. I don’t even notice when atom updates, so this just happened out of nowhere and I thought I was going insane. For it to suddenly stop working was so inexplicable, I was worried that Ctrl+click had never worked and I dreamt it.

5 Likes

I applied that fix: working

Apply fix like that:
“*”:
core:
automaticallyUpdate: false
editor:
multiCursorOnClick: true…

in config file

2 Likes

had this happen to me too, the temporary fix worked. thanks!!!

1 Like

Hi @UziTech - editing the config setting through command line as you suggested and verifying the contents in config file does NOT fix my missing multiple cursors on stable 1.48.0. Might there be anything else (other than hyperclick and IDE, which are NOT installed) that have made this stop working? First it was nightly that stopped about 2 weeks ago, then beta stopped about a week ago, now stable has stopped in 1.48.0. So something - other than the bug you referenced - has flowed down to my editor which is not fixed by the config change you posted.

@tremendus have you tried it in safe mode? That config change will fix the problem in Atom introduced in 1.48.0. If there is another problem somewhere else in your setup I would first try disabling some packages until it works too figure out which package is causing problems.

same issue here. Win10, Atom 1.48…

I hope this helps someone. When you follow UziTech’s method above, it opened for me what looked like the inspection window for a browser. I then had to click the console tab. When I entered
atom.config.set('core.editor.multiCursorOnClick', true);
as UziTech suggested, I hit enter, tested, and problem solved for now.

6 Likes

Same here. Pretty annoying. I use that feature all the time. I did recently update so I wonder if it’s just buggin out. Hope it get’s fixed soon. :triumph:

For me too ! Same problem, … waiting for a normal behaviour …
On Linux Fedora, last version, KDE Plasma

This is also happening for me, been like that for about a week. I am gonna try this cmnd line fix

Works perfectly in Atom 1.47, broken in 1.48.

1 Like

Same problem since updating to 1.48.0. The “temporary fix” above solved it for me:

4 Likes

thank you :smiling_face_with_three_hearts:

Thanks. This works like a charm.

thank you. :upside_down_face: :slightly_smiling_face: :relieved:

Thank you, great fix!

This guy is a hero

You saved me man! Thanks.