Creating your first ATOM package is broken


#1

I can no longer test my newly created package by reloading window.

I have a new package I am working on but I am unable to test it locally. Help! :smile:

The steps I have followed are:

  1. Open Atom
  2. CTRL+SHIFT+P: Generate Package
  3. Enter “C:\git\test” as name
  4. Try CTRL+SHIFT+P: test:toggle (does nothing)
  5. Try CTRL+SHIFT+P: window:reload, then repeat step 4 (still does nothign)

How do I run it?

Thanks


#2

I’ve had this recently as well.
I think if you choose the standard package folder (e.g. C:\users\[username]\.atom\packages\test), it should work again.


#3

Thanks, yeah I created the package in my local package directory and that worked. Cheers


#4

It is a well-know bug that apm link which creates the symlink to the home folder broke a few versions ago. I create the symlink manually.


#5

Ok, I didn’t use apm link explicitly, it also means the “create your first package” instructions need to be updated.

Just from someone who is not as familiar with the package archiecture, stumped me for a while :smile:


#6

apm link is used by the Package Generator package, which is what is used by the “Create Your First Package” instructions. So yes, you did use apm link. You just didn’t know it :grinning:

This is a bug. Specifically:

As documented in @mark_hahn’s topic:

Closing this topic as duplicate. Sorry for being slow on the uptake.


#7