Create new file/folder not working


#1

Hey guys n girls,

I love atom. Recently got into development and Atom rules, so sophisticated, clean, space-like. Good community around it also.

I have a glitch!
My create new file/folder is not working. I right click on a folder to create new file, type new file out as path in pop-up window and when I press enter, nothing happens, no new file, nothing!

Any ideas? This is new, all of a sudden, strange and kind of irritating: to have to add new files via the terminal.

Any ideas much appreciated.

thanks,

Losko


#2

Please follow the steps provided in the issue template and consider posting the issue on GitHub


#3

Is the folder on a network drive? Do you have access to create files in that directory? Can you reproduce the problem in Safe Mode? Have you tried the steps in the Debugging guide?

Unless people are really sure they have a bug, it is better to ask their questions here.


#4

I have gone through the debugger.

I can’t reproduce the same problem in safe mode because it doesn’t allow for folder/file creation.

There are no link issues.

I cannot seem to find the right settings for this problem and no I cannot seem to debug it. I haven’t tried to reset to factory settings as I am in development work and don’t have the time to reset everything and download each individual package again.

I might have to ask on github, but since I never have done that before I feel like waiting and seeing if I can debug it myself. I don’t go to forums the first thing I do, however I am aware that often the problems are wide spread in nature and easy to fix, that is why I to ask here.


#5

I was just able to create both a file and a folder using the Tree View in Safe Mode. Here’s what I did:

  1. Launch Atom in safe mode using atom --safe ~/Source/atom (~/Source/atom is where my Atom source repository is)
  2. Right-click on the root folder
  3. Click the “New Folder” option
  4. Type in testing as the name of the folder
  5. Press Enter

The testing folder appeared. I did the same for a file-testing file and it worked as well.


#6

No root folder appears for me in safe mode. Just an untitled script file. No root folder, or folder structure.

The problem I am having is that when I add new files to folders in the editor I can write the file name no problem, but when I click enter, nothing happens.


#7

If there is no root folder, then Atom doesn’t know where to put the folder you want to create. Use “File > Add Project Folder” first.


#8

Alright, I tried that. Behaves the same in safe mode, I can type out the file name but as soon as I hit enter it freezes, all I can do is exit, no file appears.

This could require some debugging. Is this a common issue?

Thanks


#9

No, I’ve never heard of this happening before.


#10

Hi there,
May be it can help: I had exactly the same behavior. On my Windows 7 PC the root cause was Bitdefender (AntiVirus) which prevented atom to create the file.
Cheers

Emmanuel


#11

Hey,

Yeah I do not know. Macs don’t have an anti-virus so it is not that for me. I will keep searching.

Cheers

Pavlos


#12

I am having the same issue here. Cannot create a new file, edit a file name, or create a new directory.

I first noticed this when I updated Atom. It accompanied the functionality that I could no longer open to a new tab (⌘T) without using ⇧⏎.

Very frustrating. Work around is to right click on the Atom tree directory are select ‘Show in finder’ or use the command line.


#13

Yup I have this problem still. If anyone finds out what it is all about; I am all ears. But it is not enough of a problem to spend hours trying to figure it out. I rest my case with this one.


#14

I’ve found a solution. In the file keymap.cson you have the next line by default: # 'enter': 'editor:newline'. The problem appears if you uncomment it. To solve the issue you should only comment this line again.


#15

You should try this.