Crash on launch OSX 10.7.5


#1

I can’t get Atom to open, it crashes as soon as I try to open it. Here’s the error report I get, hopefully it’s helpful:

-------------------
Process:         launchd [23686]
Path:            /Users/USER/Desktop/Atom.app/Contents/MacOS/Atom
Identifier:      com.github.atom
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [245]

Date/Time:       2014-02-27 15:43:57.467 -0500
OS Version:      Mac OS X 10.7.5 (11G63b)
Report Version:  9

Interval Since Last Report:          38159876 sec
Crashes Since Last Report:           30
Per-App Crashes Since Last Report:   10
Anonymous UUID:                      3AA5CB7F-4378-46F1-A390-4E559647DA57

Crashed Thread:  Unknown

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00007fff5fc01028

Backtrace not available

Unknown thread crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000055  rbx: 0x0000000000000000  rcx: 0x0000000000000000  rdx: 0x0000000000000000
  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x0000000000000000  rsp: 0x0000000000000000
   r8: 0x0000000000000000   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000000
  r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x0000000000000000  r15: 0x0000000000000000
  rip: 0x00007fff5fc01028  rfl: 0x0000000000010203  cr2: 0x00007fff5fc01028
Logical CPU: 0

Binary images description not available


External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 1
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 10100543
    thread_create: 2
    thread_set_state: 0

Model: iMac12,2, BootROM IM121.0047.B1E, 4 processors, Intel Core i5, 2.7 GHz, 8 GB, SMC 1.72f2
Graphics: AMD Radeon HD 6770M, AMD Radeon HD 6770M, PCIe, 512 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x80AD, 0x484D54333531533642465238432D48392020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x80AD, 0x484D54333531533642465238432D48392020
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x9A), Atheros 9380: 4.0.67.5-P2P
Bluetooth: Version 4.0.8f17, 2 service, 18 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: ST31000528AS, 1 TB
Serial ATA Device: HL-DT-STDVDRW  GA32N
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x850b, 0xfa200000 / 3
USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2
USB Device: Keyboard Hub, apple_vendor_id, 0x1006, 0xfa120000 / 5
USB Device: Apple Keyboard, apple_vendor_id, 0x024f, 0xfa122000 / 6
USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 7
USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 4
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfd110000 / 3

#2

You need 10.8: Nuclear fusion on my Mac


#3

Joy, I was trying to avoid updating to Mavericks because everyone else in my office has had issues with it.


#4

Really? I’ve been running it since the day it came out, and I haven’t had any problems. Plus, it’s already at 10.9.2 by now, which means it should be all ironed out :slight_smile:


#5

nikolaus is right. I’ve been running it since day one, haven’t had any problems with it.