Could not resolve package path (apm develop packages)


#1

Continuing the discussion from Installing modules for packages?:

I just now tried this for the first time, but I’m not able to enable the packages. When I open the console, it says Could not resolve '[package name]' to a package path. I went into the source and made a breakpoint, and followed what the program was doing, and it seems to check all the path locations except /atom/dev/packages.

Is this a bug, or did I do something wrong?


#2

Can you be more specific as to what exactly you did and what went wrong? Did you start Atom in Dev Mode with atom --dev?


#3

Does this button do that? If so, then yes.

http://puu.sh/hYD3Y/80741a26d2.png

Any package runs fine in the /packages folder, but they don’t work in /dev/packages. What I did was open Command Prompt, run apm develop language-livescript, it installed fine, but when I opened atom they wouldn’t enable (from the bottom of the package list, under ‘development packages’), no matter what mode I was in.

It didn’t error, just silently went without enabling. So then I started trying to debug and found that it didn’t even search the /dev/packages folder for the packages.


#4

The apm commands don’t take effect really until you start Atom over again completely. So what you should do is:

  1. Completely exit all instances of Atom
  2. Run your apm develop command
  3. Open Atom with atom --dev

The packages that are in ~/.atom/dev/packages should be already enabled, there aren’t any other steps you need to do.