Could not get the packages even without proxy


#1

i searched different solutions but it does not help, the error message says ECONNREFUSED 127.0.0.1:80
I’m not using proxy at home, my atom version is 1.10.2


#2

If you’re not using a proxy then you should clear the proxy settings. The above error is saying that the host at 127.0.0.1 is refusing the connection. 127.0.0.1 is the “loopback address”. It always means the machine that you’re on, so whatever configuration you have set up … it is trying to get packages from or through your local machine and your machine isn’t configured to do that.


#3

Thank you for reply sir, i tried clearing the proxy like this
npm config rm proxy
npm config rm https-proxy

and still this is the output error
tunneling socket could not be established, cause=connect ECONNREFUSED 127.0.0.1:80

do i have to configure the environment variables, or what setting should i do to my machine to make atom be able to get the packages outside?


#4

sorry that’s
apm config rm proxy
apm config rm https-proxy


#5

You may have to close and re-open your terminal?


#7

after reboot and tried to turn the firewall off and anti virus the error still insists


#8

For whatever reason, it is still trying to install packages from 127.0.0.1 which won’t work.


#9

so it seems theres no other way to solve this :disappointed:


#10

There is something configured on your system that is preventing it from connecting to the https://atom.io API to get the information it needs. I don’t know what might have done that other than the things I’ve already suggested. So yes, unfortunately, I’m out of ideas.


#11

i’m running this on 64bit OS, anyway thank you for your suggestions.