Core editor symlink to dev


#1

I went here: https://atom.io/docs/v0.152.0/contributing-to-packages, and followed the instructions.
I linked tree-view repository to dev mode, and it worked!
I tried the same thing to core editor repository: https://github.com/yjw9012/atom.git
However, that did not work. The following is the list of steps I took to link it to dev mode.

git clone https://github.com/yjw9012/atom.git
cd atom
apm install
apm link -d

I modified the code in the repo, and opened a folder in dev mode by pressing cmd-shift-o.
But, nothing happened. It was supposed to pop up a message when splitting a pane to right because I put ‘alert “Hello”’ in function split() in pane.coffee.

Does anyone know why core editor repo is not properly symlinked to dev mode?
Any help would be appreciated!


#2

The instructions you read are for contributing to packages. The core editor is not a package. See this post by @postcasio for more information on how to easily load the code you’re changing in the core editor:


#3

@leedohm Thanks for your answer! But, unfortunately, I followed the instructions described in the post, but that didn’t work either.

  1. git clone https://github.com/yjw9012/atom.git
  2. Used Sublime Text to modify source code.
  3. atom -r ./atom
  4. nothing happened!

#4

You can always just follow the build instructions as well.