Copy/Paste does not work properly


#1

Since updating to the last version of Atom (0.189.0) copy/paste does not work properly.

In detail:

  • I cannot copy something in Atom and paste it somewhere else (e.g.
    shell or other editor)
  • Sometimes Atom “dies” if I paste something copied outside (e.g. from shell or other editor)

My system:

Linux SRV027181 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Greetings Danny


Text copied in Atom won't paste in other applications
#2

Updating to Atom 0.190.0 solved the problem - something with the clipboard (see release notes).

Thx so far,
Danny


#3

Love those issues that solve themselves. :wink:


#4

I have 0.194.0 copy paste not working for me, using keyboard.


#5

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have the Emmet package installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#6

Just followed the debugging document

  • apm links -> no links
  • key bindings -> tick mark + green on core:confirm .select-list atom-text-editor[mini], tick mark + grey on core:confirm body and lot marked X
  • apm install --check -> installed

The information you asked

  • version 0.194.0
  • Ubuntu 14.10
  • Emmet is installed
  • No, in atom --safe it can’t be reproduced

#7

This indicates that a package you have installed is causing the issue. @mark_hahn’s package-cop package can be useful in tracking this kind of thing down.


#8

I don’t know what happened but, it is all gone now. I installed package-cop and tried to figure which package caused it, but all packages are cleared. And it is working now.

Thanks :smile:


#9

That’s what’s called an Heisenbug :smile:


#10

Disabed keyboard macro plugin - 1.5 and 1.6 beta had a random copy/paste isse.


#11

For others coming to this thread. For me it often relates to:

For example, I’ll open up Sublime and have the same problem. TextEdit and mac Notes seem to usually work. Something to do with RTF / plain text maybe. I’ve tried killing pboard process and nothing works, other than a complete restart of the machine :\

I’m on El Capitan. Luckily this only happens to me once a month or so.

I think I’ve tried some of these suggestions in the past to no avail:
https://discussions.apple.com/thread/1790574?tstart=0