Copy from panels stopped working (even with `tabIndex=-1` and `native-key-bindings` class)


#1

I’ve gotten reports on build-package I am maintaining that it’s not possible to copy text from a panel . I’ve had this issue before and fixed it by setting tabIndex=-1 and added the class native-key-bindings. This doesn’t seem to work anymore. There are also other people reporting this for other packages.

I can’t seem to get it to go through. The keybinding resolver doesn’t catch the c in cmd-c, which indicates that Atom may not intercept it.

cmd-c works in other places on the OS. This is at least a problem on OS X El capitan. I haven’t been able to test it on other OSs yet.


#2

Have you opened a bug on Atom about this? Which version of Atom are users reporting this on? I can confirm this using Atom v1.4.0-dev-b38e4bc on Mac OS X 10.11.1 and my package bug-report.


#3

It is reported in this issue on Atom which has the same symptoms as me.

According to it, it seems to have happened somewhere in the range of 1.0.18 and 1.1.0.

Atom Linter also had the issue. They fixed it with custom Clipboard usage: https://github.com/atom-community/linter/pull/945 . I will probably implement this workaround for now too, but it doesn’t seem as the right solution.