Context menu fails to include option for Learn Spelling


#1

Atom is primarily a code editor, so it’s incredibly annoying to see red lines all over the place when editing READMEs. Unless I’m missing something, Atom doesn’t appear to offer a way to LEARN the spelling of common words, either.


#2

There is an open Issue on this here:


#3

Thanks, Lee!

I’d upvote, but that issue is locked.

Stinks that Atom has spellcheck enabled by default, given such a major missing component.


#4

I’m pretty sure you can turn off the red lines with a css hack. I don’t have to time to check it out right now,


#5

You could also do it by disabling the spell-check package :wink: or you could do

atom-text-editor::shadow .spell-check-misspelling {
  display: none;
}