Content of the atom window pixelated

I use the actual Atom Version for C++ coding. In the last few days I have had the problem that the window contents are completely destroyed when I move the mouse (see picture). When I move the mouse, new patterns appear. I have already started Atom in Safe Mode without any improvement. The graphics card driver is also up to date. I don’t know where to look for the cause at the moment…

Any change when using …?

  • atom —disable-gpu
  • Use default themes

See if the following is helpful:
Is atom able to use the gpu?

With the -disable-gpu option I no longer have the problems. Very good, thank you very much!

Good news.

Further …
The software that manages your graphic card will have options to select which software uses what type of graphics. It may be on-board to motherboard vs external graphics card. Have a look at how the display is managed when Atom is used. You will need to put in a rule.

It will then not be required to open Atom with the --disable-gpu switch if my guess is correct.

The alternative is to create a batch / shell script to open Atom with the correct --disable-gpu switch.

What do you think?

Late note:
Please could you tell us which GPU / OS / Atom do you have?

That’s certainly a good idea. However, I use an NVIDIA Geforce 1080Ti graphics card. The driver has too many settings for me to try. Since I use Windows 10 as OS, I just added the --disable-gpu option in the start icon.

I use Atom in version 1.43.0 x64.